Credit card changes for non-US users not working
Incident Report for MongoDB Cloud
Resolved
We have completed resolving this issue. Thanks for your understanding.
Posted Mar 10, 2020 - 21:52 UTC
Identified
Due to an issue with our upstream payment provider, MongoDB Cloud customers (both Cloud Manager and Atlas) who are outside the United States are currently unable to enter or change their credit card. All customers can still use PayPal. We are working with our payment provider to correct this as soon as possible.
Posted Mar 10, 2020 - 16:46 UTC
This incident affected: MongoDB Cloud.