Atlas Cluster Creation and Modification Delays in GCP Ohio (us-east5) region

Incident Report for MongoDB Cloud

Resolved

This incident has been resolved.
Posted 12 days ago. Mar 30, 2025 - 03:00 UTC

Monitoring

The GCP incident is still ongoing and we continue to see delays in creating and modifying Atlas clusters hosted in the us-east5 region.

GCP estimated full recovery may take several hours. For details on the incident, please visit your GCP support cases page.
Posted 12 days ago. Mar 29, 2025 - 23:09 UTC

Identified

GCP confirmed there is connectivity issues with multiple Google Cloud services in zone us-east5-c starting at March 29, 2025 at 8:26:32 PM UTC.

Due to this customers may experience delays creating and modifying Atlas clusters hosted in this region.

For details, please visit your GCP support page.
Posted 12 days ago. Mar 29, 2025 - 21:58 UTC

Investigating

GCP is not successfully completing request in the us-east5-c zone and we are investigating the issue.
Posted 12 days ago. Mar 29, 2025 - 21:22 UTC
This incident affected: MongoDB Cloud.