MongoDB Atlas: Atlas cluster connectivity issues for .NET clients
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted Oct 17, 2020 - 01:47 UTC
Monitoring
Due to an issue at an upstream provider, MongoDB Atlas customers using versions of the .NET/C# drivers between 1.8 and up through 2.6.1 may be unable to connect to their clusters. We have identified that the issue is due to a failure in OCSP revocation checks.

To resolve this issue, users can either update their driver version to 2.7 or higher (preferred) or disable OCSP revocation checks. To perform the latter there are two different methods, depending on the version of your driver.

For .NET driver versions >=1.8 but < 2.0, the fix looks like this:
var connectionString = "mongodb://localhost"; // replace localhost with atlas cluster connection string
var settings = MongoClientSettings.FromUrl(new MongoUrl(connectionString));
settings.SslSettings = new SslSettings();
settings.SslSettings.CheckCertificateRevocation = false;
settings.SslSettings.EnabledSslProtocols = System.Security.Authentication.SslProtocols.Tls11 | System.Security.Authentication.SslProtocols.Tls12;
var client = new MongoClient(settings);

For .NET driver versions 2.0 through 2.6.1, the fix looks like this:
var settings = MongoClientSettings.FromConnectionString("mongodb://localhost"); //replace localhost with atlas cluster connection string
settings.SslSettings = new SslSettings();
settings.SslSettings.CheckCertificateRevocation = false;
var client = new MongoClient(settings);

Subscribers are encouraged to open cases if they require assistance or have any questions. We are working with the upstream provider to address this as soon as possible.
Posted Oct 16, 2020 - 21:34 UTC
This incident affected: MongoDB Cloud.