Creating new clusters and updating existing clusters is delayed
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved. Thanks for your patience.
Posted Apr 02, 2020 - 18:17 UTC
Investigating
Creating new clusters and updating existing clusters is delayed. We are investigating this issue and will update this post when we have further information.
Posted Apr 02, 2020 - 17:39 UTC
This incident affected: MongoDB Cloud.