MongoDB Support Phone System is down
Incident Report for MongoDB Cloud
Resolved
This issue has been resolved. It was caused by an infrastructure issue at the vendor's end.
Posted Jul 18, 2020 - 00:50 UTC
Investigating
The MongoDB Support phone system is currently down. We are investigating the root cause. If you have a case needing immediate attention please let the support engineer know by adding a case comment indicating you would like a call back.
We apologize for any inconvenience this may cause.
Posted Jul 17, 2020 - 21:46 UTC
This incident affected: MongoDB Support Portal.