MongoDB Cloud: Users may reach a blank page upon login
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted Aug 24, 2022 - 20:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2022 - 19:02 UTC
Identified
We have identified an issue causing users who are attempting to login to be greeted with a blank white page instead of their Atlas or Cloud Manager deployments. As a workaround, users can navigate to https://account.mongodb.com/account/login to complete the login process.

The health of clusters, their backups, or their monitoring is unaffected.
Posted Aug 24, 2022 - 18:21 UTC
This incident affected: MongoDB Cloud.