MongoDB Cloud experiencing slow page loads for some pages
Incident Report for MongoDB Cloud
Resolved
This incident has been resolved.
Posted Nov 04, 2022 - 17:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 04, 2022 - 17:20 UTC
Identified
We have identified an issue causing slow page loads or page load failures on cloud.mongodb.com. Affected customers may see page loads take exceptionally long periods of time or timeout entirely. Cluster health is unaffected. MongoDB Atlas and Cloud Manager API endpoints are affected. Cluster creation and certain healing operations may also be delayed.

Creating, modifying, or viewing MongoDB Charts is also impacted.

Creating, modifying, or viewing Atlas App Services may be delayed as well.

Modifying or creating MongoDB Atlas Data Federation and Data Lake resources may also be delayed.
Posted Nov 04, 2022 - 17:13 UTC
This incident affected: MongoDB Cloud, MongoDB Atlas App Services and Device Sync, MongoDB Atlas Data Federation and Online Archive, and MongoDB Charts.